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Overview 
With FastTrack, our ParsePort Platform is capable of merging annual reports in ePub 
format with the Excel Tagging Template. The ePub file is exported from InDesign, which 
is where the annual report is created.  

FastTrack enables issuers to block tag notes using InDesign, in combination with 
ParsePort’s TextSearch technology. The use of FastTrack has several advantages. It 
allows for: 

●​ ePub & native HTML support to maintain pixel-perfect reports 
●​ Table tagging support for meaningful HTML and compliant reporting 
●​ Tagging (and ability to change tags) at any point in the reporting process 

​
This document intends to provide an overview of the settings needed to properly 
prepare InDesign files and to subsequently export ePub for conversions. 

 

To ensure a proper ePub, two essential tasks must be performed. 

1.​ Verify that the layers in InDesign adhere to the correct reading order. 
2.​ Specify the parts of the text that have to be tagged.  

​
Without these basic assumptions, the order of the text won’t be correct, and TextSearch 
cannot work properly. 

Goals 
1.​ Understand the steps needed to use FastTrack. 

2.​ Learn the settings to apply for correct ePub exports. 

3.​ Learn how to work with related InDesign functions. 
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Steps 

I.​Opening the InDesign file 
Start by opening the InDesign file. This file will most likely be located within a  ‘.zip’ 
folder. Inside, you will find two more folders; one is called ‘MACOSX’ and is reserved for 
Mac users; the other (regardless of the name) is the file you will need to use.  

 

Inside this one the kind and number of files may vary, but you will have to look for an 
InDesign document.  

Please note that the InDesign document is different from the InDesign Markup 
Document (.idml); this file should not be opened. The InDesign document can be 
recognized by its file extension (.indd). This is the file that contains all the data used to 
create the report. 

 

Once you have found it, you can open it either by double-clicking or through the 
InDesign menu (File > Open). 
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II.​Prepare your InDesign workspace  
Next, you will need to prepare your workspace correctly. One of the key assumptions 
for FastTrack is that the layers are in the correct order; therefore, you must access the 
layer panel and reorder the layers accordingly. 

Accessing the Layers panel 

To access the panel displaying the layers on a specific page, follow these steps: Click on 
the ‘Window’ option in the top bar, then select ‘Layers’. This will open the panel on the 
right side, allowing you to view the layers present on the page.  

For easy access, make sure to pin the Layer panel to your right sidebar.  
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Ensuring proper table output 

Besides prepping your InDesign workspace, you must also ensure that your tables in 
your InDesign file are prepped. Our solution, FastTrack, offers a block note tagging 
feature that enables you to present tables as actual tables in the HTML output. This 
aligns with the new ESMA requirement known as 'meaningful HTML,' which mandates 
that tables in the 'Notes to the Financial Statements' be displayed as properly 
structured tables. FastTrack has the capability to meet this requirement.  

To ensure compliance, it is important for designers to create tables using the dedicated 
table functionality in InDesign rather than using regular text boxes. By inserting proper 
tables, the desired outcome can be achieved seamlessly. 
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III.​Ordering the layers 
Now that you are able to see the layers, you can start checking the order and, where 
needed, rearrange the layers or sublayers. The following paragraph explains how the 
layers and their sublayers need to be ordered. 

Determining the correct layer order 

When exporting an InDesign file to a native HTML format like ePub, it's important to 
note that the layer order is reversed.  

For instance, a sublayer that appears at the top of the Layer panel in InDesign is at the 
bottom of the HTML file. Therefore, the order must be reversed. When the order is 
reversed, our Platform can read the file in the correct order. 

Reordering layers manually 

To visually identify where the layer is located and what it contains, click on the eye icon 
that is next to the layer or sublayer. As for ordering, you can simply drag and drop the 
layer to move its position.  

The section or (sub)layer that should be read first must be at the bottom, and the 
section that should be read last needs to be at the top (see screenshot). 

The order of layers becomes irrelevant when they are not going to be tagged. 

Troubleshooting problems when ordering layers manually 

Ordering layers manually can be challenging when dealing with nested items and 
groups. In some cases, (sub)layers within groups cannot be moved manually, depending 
on how the groups are structured. 
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To overcome this, it is recommended to ungroup the group first and then move the 
individual (sub)layers. If you have merged or nested groups (i.e., groups in groups),  it is 
advisable to ungroup all groups.  

In such situations, using a script can be the most efficient approach. Please refer to 
section IV. 
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IV.​Using a script to order the layers  
The layers can be reordered automatically using a custom ParsePort script.  

The script will reorder all containers based on their top left position and all layers from 
top to bottom, left to right. This should be correct in almost all traditional layouts with 
one or more columns.  

The script will reorder all layers present in the document, not just a specific page or 
section.  

When to combine script and manual layer reordering – Creative layouts 

It could be that certain pages are laid out in such a way that they require manual 
reordering.  

An example of this would be when containers such as text boxes and images are placed 
on top of each other, and/or do not follow your typical reading order (top to bottom or 
left to right). Therefore, before using this option, it is important to verify whether there 
are any pages that require manual reordering.  

Example 1 

The screenshot below details such a case. This section contains two text boxes on a 
dark background and should be read left to right, but if the script would reorder these 
layers, the reading order would be column 1, followed by column 3 and then column 2.  

To ensure that the ParsePort Platform reads this ePub correctly, we would have to use 
the script first, and manually reorder layers 1 and 2.  
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If there are, it is recommended to use the script first and then manually reorder the 
specific pages that need it. For guidance on reordering layers manually, refer to Section 
III. 

Example 2 

The second example details another case where manual alterations from the designer 
are needed. 

In this example, the text boxes are incorrectly stacked on top of each other, causing 
improper ordering when converted on the Platform. 

This page contains several Containers and Text Boxes: 

1.​ The general text is placed in Text Box 1 (from “The Group”  to “(see Note 5.1.)”) 
2.​ The headers are NOT included in Text Box 1 (green), and are instead placed in 

separate text boxes ON TOP of Text Box 1. See Group 2 (light blue) and 3 (dark 
blue).  

-​ The header groups contain three elements: 
-​ Header text (i.e. Strategic capital management) 
-​ Number (i.e. 32) 
-​ Filled in frame (i.e. red box) 

If we utilize the script to automatically reorder the content, the order of the HTML 
output would look like this: TextBox 1, Group 2, and Group 3.  

In the HTML output, the headers do not follow the order as they visually appear in the 
InDesign file, because the Text Boxes/Containers are stacked on top of each other.  

This is NOT what we want. The headers should be included within the text, and should 
not be read after Text Box 1.  
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There are two solutions. 

1.​ Add your headers within the general text box (in this case ‘Text Box 1’). Do not 
separate or place headers on top of general text both but add headers within 
the box. 

2.​ If you use specific styling for your section numbers (in this case ‘number 32 and 
31 on a dark background’), make sure that style is defined as a bullet list style. 
This way, your section number and header title are one, and can be included 
within the general text (in this case ‘Text Box 1’) 

-​ If you do not have specific section numbers like the example above, you 
will still need to perform Solution 1. 
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How to install the ParsePort script 

Windows 

●​ Please request the script file from ParsePort Support. Place the file under:  
●​ C:\Users\[username]\AppData\Roaming\Adobe\InDesign\Version 

18.0\en_US\Scripts\Scripts Panel.  
●​ After that, you will be able to activate it by double clicking its name under 

Window > Utilities > Scripts > User 
●​ To uninstall the script: Remove it from the Scripts within your C:/ folder. 

Mac 

●​ Please request the script file from ParsePort Support.  
●​ Open your ‘Applications’ folder > Open the ‘InDesign application’ folder > Open 

the ‘Scripts’ folder > Drag in the ParsePort script > Relaunch InDesign 
●​ After that, you will be able to activate it by double clicking its name under 

Window > Utilities > Scripts > User 
●​ To uninstall the script: Remove it from the Scripts folder with the application 

folder.  

How to revert the script reordering process 

In case you want to undo the script reordering process, you can use the undo button in 
InDesign.  

Alternatively, you can use the keyboard shortcut for undoing an action. On Mac, press 
CMD+Z, and on Windows, press CTRL+Z. 
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V.​Defining which part of the report to tag  
Now that you have ordered the layers in the correct reading order, the last thing to do 
is to define which part of the text needs to be tagged. If this is not defined, our engine 
will assume all text requires tagging. 

With TextSearch, this identification was done by creating hyperlinks within your PDF 
containing ‘area://text’. With FastTrack, you will need to add the epub:type attribute to 
containers.  

What is an epub:type? 

An epub:type is an attribute that is often used to enhance the user experience in EPUB 
reading systems. In this case, the epub:type attribute is used to instruct our engine 
what to tag.  

Defining what to tag – Selecting containers 

A container typically encompasses all the text within a column, page, or table. You can 
select a container by either clicking directly on it or hovering your mouse over a specific 

page (ensure you are using this  tool). Additionally, you have the option to select 
multiple containers simultaneously by holding down the shift key.  

Unfortunately, due to the limitations of InDesign, you cannot select all containers from 
all pages at the same time. 

When selecting containers, you might notice that some containers have different 
colored borders. Each color corresponds to a different layer within your document. 
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In the example above, you can see 4 containers, all selected using ‘Shift’. 

Adding the epub:type attribute to containers 

After you have selected the containers that are related to the section/pages you want to 
tag, right-click on them and select 'Object Export Options'. 

Select the tab ‘EPUB and HTML’ and write ‘bodymatter’ in the epub:type box: 

13 of 29 



 

Repeat this process for each page/section that has to be tagged, including the 
consolidated statements. Again, due to the limitations of InDesign, you cannot select 
all containers from all pages at the same time, meaning that this process must be 
repeated. 
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VI.​Using a script to apply the ePub:type  
Similar to our layer ordering process, we can use a script to speed up this process. This 
script installs a shortcut that you can use to apply the epub:type attribute (bodymatter) 
to all containers within a page. 

Please note that it does not apply the attribute to all containers within the entire 
document. Only on the ones you select within a page/spread. The script provides a 
shortcut to automate the application of the epub:type attribute to the container. But 
you must still repeat this process for each page/spread. 

How to install the ParsePort script 

Windows 

●​ Please request the script file from ParsePort Support. Place the file under:  
●​ C:\Users\[username]\AppData\Roaming\Adobe\InDesign\Version 

18.0\en_US\Scripts\Scripts Panel 
●​ Relaunch InDesign if necessary. 
●​ To uninstall the script: Remove it from the Scripts within your C:/ folder. 

Mac 

●​ Please request the script file from ParsePort Support.  
●​ Open your ‘Applications’ folder > Open the ‘InDesign application’ folder > Open 

the ‘Scripts’ folder > Drag in the ParsePort script > Relaunch InDesign 
●​ To uninstall the script: Remove it from the Scripts folder with the application 

folder.  

Using the Script to automatically add the epub:type attribute to 
containers 

1.​ Go to 'Edit' in the top menu and select 'Keyboard Shortcuts.' 

2.​ In the Keyboard Shortcuts dialog box, choose the product area 'Scripts.' 
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​  

3.​ Locate the 'BodyMatter' script and click on it. 

4.​ In the bottom left corner of the dialog box, enter your desired shortcut. 

You can choose any shortcut that you prefer, as long as it doesn't conflict with other 
shortcuts. Tip: Ctrl+Spacebar is not assigned to anything by default. 

After setting a desired shortcut for this action, select all containers on every page and 
use the shortcut to apply the epub:type attribute (bodymatter) to containers.  

Repeat for each page/spread. 

 

 

VII.​Exporting the ePub file 
Finally, when the order is set correctly and the taggable areas are determined, the 
InDesign file can be exported to ePub.  

This can be done via File > Export. You must save it as ‘EPUB (Fixed Layout)’.  

After this, you have the option to change certain settings. Generally speaking, there is 
no need to make any changes, and you can simply click ‘OK’ to initiate the export 
process. Just be sure that the option ‘All pages’ is selected (unless you want to export 
specific pages only). 
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VIII.​Troubleshooting issues 
​
Please take note of certain limitations that may exist with ePUB files. While we have 
identified potential solutions for all the issues, it's important to consider that their 
effectiveness will vary depending on the specific circumstances of each case. 

1. Kerning and font embedding issues 

Adobe has noted a limitation regarding kerning and ePUB exports: 

“Kerning is not supported on an individual glyph and is distributed as letter 
spacing across all the letters of a word.” See the original source here. 

Often, designers use kerning on a single letter or word. Sometimes this does not 
translate well to ePUB.  

Possible solutions 

To address the problem, we recommend considering the following suggestions: 

1.​ Ensure that you apply kerning to the entire word or sentence.  

2.​ Include the kerning settings within the paragraph or character style, rather than 
adding a separate style on top. Instead, combine the two styles.  

3.​ To check if a piece of text has an additional style applied, open the Paragraph 
Style window and click on the 'Style Override Highlighter' button. The presence 
of a '+' symbol next to the Paragraph Style name also indicates when additional 
style overrides have been applied. 

 

4.​ It is possible that the issue could be related to font embedding. This occurs 
because font embedding in EPUB files is typically not included in standard font 
End User License Agreements (EULAs). As a result, obtaining the appropriate 
license may require additional steps. 

​ In this case, please check with your font foundry to obtain an ePUB font license.  

18 of 29 

https://helpx.adobe.com/uk/indesign/using/export-content-epub-cc.html


2. Exporting Fractions to ePUB 

HTML, the format of an ePUB, does not support OpenType formatting, which includes 
fractions. Therefore, it is not possible to use fractions in ePUB.  

The image below showcases an example of the use of Fractions, and where the 
OpenType formatting options are (click on the text container or select text > Hamburger 
menu on the left > OpenType > Fractions). 

 

Possible solutions 

To address this limitation, you can remove the fractions formatting from your content. 
Alternatively, you can reformat the fractions manually using traditional methods.  

This involves using superscript and subscript or adjusting the font size of the left and 
right numbers. 

1. Using super/subscript 

Select the number > a box appears with super/subscript options > click the desired 
option. 
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2. Manually adjusting the font size 

Select the number > adjust the font size. 
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3. White spaces are not visible in ePUB  

When exporting reflowable ePUB files, it's important to note that tabs and blank spaces 
may not be preserved. 

Generally, this should not be an issue when using FastTrack, as tabs and blank spaces 
are preserved in the ePUB Fixed Layout format. 

However, to maintain the desired spacing between paragraphs, it is always 
recommended to use the Non-breaking space feature (found under Menu Type > Insert 
White Space > Non-breaking space) in conjunction with the paragraph character. 

Please note that other White Space functions (eg. Em/En spaces) may not be preserved 
on ePUB files. 

4. Multiply effect is not supported in ePUB 

Certain effects, such as the multiply blending mode, are not compatible with ePUB. 

Possible solution 

In order to ensure that certain effects are functional in an ePub, it is necessary to 
rasterize them.  

All elements that have the multiply effect applied should be grouped together.  

Once grouped, select the entire group and access the Object Export Options (use the 
selection tool to select the grouped container > right click > click Object Export Options). 
Apply the following settings: 
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This will generate a rasterized version that includes the multiply effect. It's important to 
note that objects affected by a blend mode must be grouped together for this method 
to work. 

5. Multiple effect not supported in ePUB 

Certain effects, such as the gradients, are not compatible with ePUB. 

Possible solution 

To ensure that gradient fill and strokes, like linear and radial gradients, are compatible 
with ePUB, you can convert the affected elements into graphics. 

This can be achieved by rasterizing the containers where the gradients are applied. By 
doing so, you can ensure that the elements will display correctly in an ePUB format. 

All elements that have the gradient effect applied should be grouped together.  

Once grouped, select the entire group and access the Object Export Options (use the 
selection tool to select the grouped container > right click > click Object Export Options). 
Apply the following settings: 
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6. Vertical text in tables becomes unreadable  

Unfortunately, ePUB does not support vertical text (text rotated 90 degrees) in fixed 
format, which is the required format for your ePUB file conversion. Therefore, vertical 
text in tables will not convert properly, resulting in unreadable text (see the example 
below). 

An example of text rotated 90 degrees in a table (1) and its appearance in XHTML (2): 
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Possible solution 

Presently, there are no immediate solutions available to rectify this issue, as vertical 
text is not a supported feature of ePUB.  

Our recommendation is to align the text horizontally within your tables. This 
adjustment may necessitate altering the table design to accommodate horizontally 
aligned text. 

7. Splitting tables – One table appearing as two separate tables 

It's possible that a single table has been styled to appear as two separate tables. Below, 
we have provided an illustration of this setup.  
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Visually, it gives the impression of two distinct tables, with a line of text (C) dividing what 
appears to be the first (A) and second table (B). However, technically, it is created as a 
single table where the line of text (C) has been styled differently. 

 

Our Platform is unable to split this table during conversion and thus cannot tag both 
tables separately. 

Possible solution 

To address this issue, the table needs to be manually split and transformed into two 
independent tables.  

Failure to do so may result in a similar output in the rendered HTML as shown below. 
Here both tables are tagged as one. 
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8. How to create report with different layouts (Vertical and Horizontal) 

To create a report that contains both vertical and horizontal layouts, you need to export 
two (or more) separate ePub files that will be subsequently merged on our Platform. In 
fact, even if the tall and wide pages appear correct when combined in InDesign, 
exporting to ePub will use the “master” page size, defined in “Document Setup”, taking 
over the other. If these steps are not followed the final report will have cut pages and 
missing text. 

Possible solution 

You can navigate through the “Document Setup” menu and select portrait or horizontal 
orientation, this will be applied to the whole document. After that, export to ePUB only 
the pages related to the selected layout (e.g. one file with horizontal layout and another 
with portrait orientation). Note that you can easily select multiple pages to export under 
the field ‘Export Range’. 
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After the export, to define the merging order of these files you will need to add 
'underscore' followed by sequential numbering (starting by 1) to any text used for 
naming the files. So for example if you have 4 files to merge this would be the correct 
naming convention: 

●​ (any text)_1 
●​ (any text)_2 
●​ (any text)_3 
●​ (any text)_4 

Once done, you can just upload these files on our Platform and they will be merged 
accordingly. 

 

9. How to combine multiple reports in one single document  

If your annual report is being designed in two or more different InDesign documents, it 
is possible to gather these in one collective document with the Book feature in 
InDesign.  
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Possible solution 

1. Open InDesign and open one of the documents you want to combine with other 
components.  

2. Click file, then click new, and proceed to click the 'book' option in the menu. See 
screenshot below:  

 
3. Save the book in the folder of your choice. It is important that the ‘Save as type’ is set to 
Book. 
4. Add documents to your newly created Book. This is done by clicking ‘+’ and choosing the 
InDesign documents you want to be part of the collective document. See screenshot below: 

 
 
Continue adding until you have all components included in the Book. 
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5. Click the Burger menu in the top right corner of the Book feature box and subsequently 
click ‘Export Book to EPUB’. Remember to save the ePUB as a ‘EPUB (Fixed Layout). 

 
8. Please note that all future changes in the separate documents should be carried over 
automatically to the Book, so you do not have to create a new book every time changes are 
made to the original InDesign documents. If you are unsure that the changes are carried 
over to the book automatically, you can use the ‘Update All Cross-References’, available in 
the same Burger menu as mentioned above. 
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